Artifact Content
Not logged in

Artifact a388e88c7cfacd7f2e3656153e05df823cef7cfb:


{
  "name": "ilp-kit-client",
  "version": "4.0.0",
  "description": "ILP kit client",
  "license": "Apache-2.0",
  "repository": {
    "type": "git",
    "url": "https://github.com/interledgerjs/ilp-kit"
  },
  "author": "Interledger Team <info@interledger.org>",
  "keywords": [
    "five-bells",
    "ilp",
    "ledger",
    "wallet",
    "ui",
    "payments",
    "finance"
  ],
  "scripts": {
    "start": "node scripts/client.js",
    "build": "node scripts/build.js",
    "test": "node scripts/test.js --env=jsdom"
  },
  "dependencies": {
    "autoprefixer": "7.1.1",
    "babel-core": "6.25.0",
    "babel-eslint": "^7.2.3",
    "babel-jest": "20.0.3",
    "babel-loader": "7.1.2",
    "babel-preset-react-app": "^3.0.1",
    "babel-runtime": "6.23.0",
    "bootstrap-loader": "^2.2.0",
    "case-sensitive-paths-webpack-plugin": "2.1.1",
    "chalk": "^1.1.3",
    "classnames": "^2.2.5",
    "clipboard": "^1.7.1",
    "concurrently": "^3.5.0",
    "css-loader": "0.28.7",
    "currency-symbol-map": "^4.0.1",
    "dotenv": "4.0.0",
    "eslint": "^4.13.1",
    "eslint-config-react-app": "^2.0.1",
    "eslint-loader": "1.9.0",
    "eslint-plugin-flowtype": "^2.40.1",
    "eslint-plugin-import": "^2.8.0",
    "eslint-plugin-jsx-a11y": "^5.1.1",
    "eslint-plugin-react": "^7.5.1",
    "extract-text-webpack-plugin": "3.0.0",
    "file-loader": "1.1.4",
    "font-awesome": "^4.7.0",
    "font-awesome-loader": "^1.0.2",
    "fs-extra": "^4.0.1",
    "history": "^4.6.3",
    "html-webpack-plugin": "2.30.1",
    "jest": "20.0.4",
    "moment": "^2.19.3",
    "node-sass": "^4.5.3",
    "object-assign": "4.1.1",
    "piping": "^1.0.0-rc.4",
    "postcss-flexbugs-fixes": "3.0.0",
    "postcss-loader": "2.0.6",
    "promise": "7.1.1",
    "prop-types": "^15.5.10",
    "react": "^15.6.1",
    "react-addons-css-transition-group": "^15.6.0",
    "react-animate-on-change": "^1.0.0",
    "react-bootstrap": "^0.31.2",
    "react-bootstrap-table": "^3.5.1",
    "react-dev-utils": "^3.0.2",
    "react-dom": "^15.6.1",
    "react-dropzone-component": "^2.0.0",
    "react-error-overlay": "^1.0.9",
    "react-fittext": "^1.0.0",
    "react-ga": "^2.2.0",
    "react-helmet": "^5.1.3",
    "react-hotkeys": "^0.10.0",
    "react-paginate": "^4.4.3",
    "react-redux": "^5.0.5",
    "react-redux-loading-bar": "^2.9.2",
    "react-router": "^4.1.2",
    "react-router-bootstrap": "^0.24.2",
    "react-router-dom": "^4.1.2",
    "react-router-redux": "^5.0.0-alpha.6",
    "react-timeago": "^3.4.3",
    "react-tooltip": "^3.3.0",
    "react-transition-group": "^2.2.0",
    "redux": "^3.7.2",
    "redux-devtools-extension": "^2.13.2",
    "redux-form": "^7.0.3",
    "redux-pagination": "^0.2.0",
    "resolve-url-loader": "^2.1.0",
    "riek": "^1.1.0",
    "sass-loader": "^6.0.6",
    "socket.io-client": "^2.0.3",
    "style-loader": "0.18.2",
    "superagent": "^3.5.2",
    "superagent-mocker": "^0.5.2",
    "sw-precache-webpack-plugin": "0.11.4",
    "url-loader": "0.5.9",
    "uuid4": "^1.0.0",
    "webfinger.js": "^2.6.5",
    "webpack": "3.6.0",
    "webpack-dev-server": "2.9.1",
    "webpack-manifest-plugin": "1.3.2",
    "webpack-sentry-plugin": "^1.14.0",
    "whatwg-fetch": "2.0.3"
  },
  "jest": {
    "collectCoverageFrom": [
      "src/**/*.{js,jsx}"
    ],
    "setupFiles": [
      "<rootDir>/config/polyfills.js"
    ],
    "testMatch": [
      "<rootDir>/src/**/__tests__/**/*.js?(x)",
      "<rootDir>/src/**/?(*.)(spec|test).js?(x)"
    ],
    "testEnvironment": "node",
    "testURL": "http://localhost",
    "transform": {
      "^.+\\.(js|jsx)$": "<rootDir>/node_modules/babel-jest",
      "^.+\\.css$": "<rootDir>/config/jest/cssTransform.js",
      "^(?!.*\\.(js|jsx|css|json)$)": "<rootDir>/config/jest/fileTransform.js"
    },
    "transformIgnorePatterns": [
      "[/\\\\]node_modules[/\\\\].+\\.(js|jsx)$"
    ],
    "moduleNameMapper": {
      "^react-native$": "react-native-web"
    },
    "moduleFileExtensions": [
      "web.js",
      "js",
      "json",
      "web.jsx",
      "jsx"
    ]
  },
  "babel": {
    "presets": [
      "react-app"
    ],
    "plugins": [
      "transform-decorators-legacy"
    ]
  },
  "eslintConfig": {
    "extends": "react-app"
  },
  "devDependencies": {
    "babel-plugin-transform-decorators-legacy": "^1.3.4",
    "bootstrap-sass": "^3.3.7"
  }
}