Artifact Content
Not logged in

Artifact 9b0219dd031912b0ade129573b7f7c1d0c7f647e:


{
  "name": "safe-app",
  "version": "0.0.1",
  "description": "",
  "main": "src/index.js",
  "scripts": {
    "lint": "eslint src test",
    "fix-lint": "eslint --fix src test",
    "postinstall": "download_deps --package package.json",
    "docs": "documentation build --config etc/documentation.yml --github true --output docs --format html src/**",
    "serve-docs": "documentation serve --config etc/documentation.yml --github true --output docs --format html src/**",
    "test": "mocha",
    "test-coverage": "istanbul cover _mocha --report lcovonly -- -R spec",
    "publish-coverage": "cat ./coverage/lcov.info | ./node_modules/coveralls/bin/coveralls.js"
  },
  "repository": {
    "type": "git",
    "url": "git+https://github.com/maidsafe/safe_app_nodejs.git"
  },
  "author": "",
  "license": "ISC",
  "bugs": {
    "url": "https://github.com/maidsafe/safe_app_nodejs/issues"
  },
  "homepage": "https://github.com/maidsafe/safe_app_nodejs#readme",
  "dependencies": {
    "deps_downloader": "git+https://github.com/gnunicorn/deps_downloader.git",
    "enum": "^2.3.0",
    "ffi": "^2.2.0",
    "ref": "^1.3.3",
    "ref-array": "^1.2.0",
    "ref-struct": "^1.1.0",
    "weak": "^1.0.1"
  },
  "devDependencies": {
    "coveralls": "^2.13.0",
    "documentation": "^4.0.0-beta.18",
    "eslint": "^3.12.2",
    "eslint-config-airbnb-base": "^11.0.0",
    "eslint-plugin-import": "^2.2.0",
    "istanbul": "^0.4.5",
    "jsdoc": "^3.4.3",
    "mocha": "^3.2.0",
    "mocha-lcov-reporter": "^1.3.0",
    "should": "^11.1.2"
  },
  "download_deps": {
    "system_uri": {
      "mirror": "https://github.com/gnunicorn/system_uri/releases/download/v",
      "version": "1.0.0-pre",
      "targetDir": "src/native",
      "filePattern": "^.*\\.(dll|so|dylib)$"
    },
    "safe_app": {
      "mirror": "https://github.com/krishnaIndia/safe_core/releases/download/v",
      "version": "0.1.0-pre32",
      "targetDir": "src/native",
      "filename": "safe_app-dev",
      "filePattern": "^.*\\.(dll|so|dylib)$"
    },
    "ENV": {
      "win32": {
        "libwinpthread-1": {
          "mirror": "https://github.com/gnunicorn/safe_core/releases/download/v",
          "version": "0.1.0-pre3",
          "targetDir": "src/native",
          "filePattern": "^libwinpthread-1.dll$"
        }
      }
    }
  }
}