Artifact Content
Not logged in

Artifact 4c512e6c70408e9d1ac066a8cf4d0a3d7ec09137:


Sentry On-Premise Build Status

Official bootstrap for running your own Sentry with Docker.

Requirements

Minimum Hardware Requirements:

Setup

To get started with all the defaults, simply clone the repo and run ./install.sh in your local check-out.

There may need to be modifications to the included docker-compose.yml file to accommodate your needs or your environment (such as adding GitHub credentials). If you want to perform these, do them before you run the install script.

The recommended way to customize your configuration is using the files below, in that order:

If you have any issues or questions, our Community Forum is at your service!

Securing Sentry with SSL/TLS

If you'd like to protect your Sentry install with SSL/TLS, there are fantastic SSL/TLS proxies like HAProxy and Nginx. You'll likely want to add this service to your docker-compose.yml file.

Updating Sentry

Updating Sentry using Compose is relatively simple. Just use the following steps to update. Make sure that you have the latest version set in your Dockerfile. Or use the latest version of this repository.

Use the following steps after updating this repository or your Dockerfile:

docker-compose build --pull # Build the services again after updating, and make sure we're up to date on patch version
docker-compose run --rm web upgrade # Run new migrations
docker-compose up -d # Recreate the services

Resources